Installation of IonCube Loader on any variaty of Linux is very simple.

Just get the copy from ioncube webpage itself, http://www.ioncube.com/loaders.php
We will download the 64-bit version for our example.

Then extract the file, copy the shared object file that matches your PHP version to an appropriate folder.
To learn your PHP version you can simple grep the php -i output.

After copying the shared object, add a few lines to your php.ini and that’s it.

wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz
 tar -xvzf ioncube_loaders_lin_x86-64.tar.gz
# learn php version
 php -v
# let's say it's 5.2
 mkdir /usr/local/ioncube
 cp ioncube/ioncube_loader_lin_5.2.so /usr/local/ioncube
# locate your php.ini file
 php -i|grep php.ini

Add the lines below at the end of your php.ini file.
[ code lang=”bash” ]
zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so
[ /code ]

About The Author